Website Technical Help

In order to use our Web site, you will need certain software and capabilities on your computer.  For some of our secure online features, you will need Microsoft Internet Explorer 5.5, 6.0 or 7.0.  In order to see some documents on our site -- forms, comparison charts, rate charts, etc. -- you will need Adobe Acrobat 7.0 or higher.